[Android Studio][Windows] Emulator: Incompatible HAX module version 3,requires minimum version 4

熱門文章 (Popular Post)

Posted by : Duran Hsieh 2018-03-18

問題 (Error Message)

當安裝模擬器並啟動 Android 程式時,得到了下列錯誤訊息
I created a new virtual device in Android Studio. I want to run app on it, but I get following error message:

Emulator: Incompatible HAX module version 3,requires minimum version 4
Emulator: No accelerator found.
Emulator: failed to initialize HAX: Invalid argument




解決方法 (Solution)

步驟1. 找到Android SDK Folder。您可以在 Tools  Android  SDK Manager 找到資料夾位置。
Step 1.Find your Android Folder. You can find the folder path in Tools  Android  SDK Manager




步驟2. 移動至 extras\intel\Hardware_Accelerated_Execution_Manager\ ,執行 intelhaxm-android.exe
Step 2. Open  extras\intel\Hardware_Accelerated_Execution_Manager\ , find and run intelhaxm-android.exe



步驟3. 安裝完成後,重新啟動程式,完成。
Step3. After installation, run app again, it works.


Leave a Reply

Subscribe to Posts | Subscribe to Comments

- Copyright © Duran Hsieh @ Duran 的技術冶煉廠 - Date A Live - Powered by Blogger - Designed by Johanes Djogan -